Honda Car Forum


 

Go Back   Honda Car Forum - Accord Parts Civic Tuning Acura Racing > Discussion > Honda Technical

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Jul 2008, 10:37 am
Junior Member
 
Join Date: Jul 2008
Location: Newfoundland,Canada
Posts: 2
Default Brake problem???

Hi, I,m new to this and this is my first post so bear with me.I am the owner
of a 1999 Honda Accord sedan.There is a bad vibration in the rear of the
vehicle when braking at highway speed. I have replaced front pad and rotors,
and also rear drums, shoes and spring hardware.Vibration is still there. I am
totally baffled. Is there anyone out there with any suggestions on this problem.Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake problem Philip Trenholme Honda 3 3 17 May 2006 10:57 pm
Brake problem Philip Trenholme Honda 3 0 17 May 2006 06:39 pm
Brake problem gearshift Honda 3 1 04 Oct 2005 09:06 pm
Re: Brake Problem Tegger Honda 3 0 16 Jul 2003 07:48 pm
Re: Brake Problem Zebra Honda 3 0 14 Jul 2003 09:57 am


All times are GMT -5. The time now is 03:14 pm.


Attribution:
Honda News | Autoblog
Powered by Yahoo Answers




Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
HondaCarForum.com is not affiliated with Honda Motor Company in any way. Honda Motor Company does not sponsor, support, or endorse HondaCarForum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.