Honda Car Forum


 

Go Back   Honda Car Forum - Accord Parts Civic Tuning Acura Racing > Discussion > Honda Technical

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Apr 2008, 08:01 pm
Tee Tee is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Default Honda fuel pump...please help!?

I had a 90k mile work done on my 99 Honda Passport EX 6-cyl...pretty much everything from A to Z. Prior to that, my truck would take a couple of cranks to start. The shop that worked on it said that they would check all belts, fuses, etc and said nothing was wrong. Lo and behold, my truck died about two weeks after that. It turned out to be my fuel pump. I had it replaced and now it is making this humming noise and the engine light came on twice since it's been replaced with a code of "Evap sensor pressure low". My mechanic said he notices the light (& this code) comes on after I've gotten gas within the past 48hrs, so I've been tightening my gas cap more than normal after I get gas and that's helped.My problem now is that when it sits, it takes a few cranks to get it started. This is what was happening before. I can't afford to get another vehicle and am being drained due to repairs. Any suggestions on what it could be or should I just take it to the dealer?
Reply With Quote
  #2 (permalink)  
Old 13 Apr 2008, 08:16 pm
Junior Member
 
Join Date: Apr 2008
Posts: 1
Default

Replace the fuel filter and put a new gas cap on it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1991 acura integra fuel pump changed and distrubuter now I am not getting any fuel to my injectors? eyora112534 Acura Technical 2 26 Aug 2007 09:18 am
my acura integra has a code #43 fuel supply does this mean it is the fuel pump? eyora112534 Acura Technical 3 26 Aug 2007 08:08 am
1989 Honda Accord Lxi. Bad computer? No fuel coming out of injectors. Fuel pump works hot wired.? zzzaaakkk Honda Technical 3 25 Aug 2007 01:18 pm
Have a 93 del sol SI Will not start 40% of the time -new Fuel filter did not help.Fuel pump-? Paul Honda Technical 2 25 Aug 2007 12:10 pm
fuel filter and fuel pump on an 89 integra Max Honda 3 9 26 Sep 2003 03:36 am


All times are GMT -5. The time now is 08:16 am.


Attribution:
Honda News | Autoblog
Powered by Yahoo Answers




Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
HondaCarForum.com is not affiliated with Honda Motor Company in any way. Honda Motor Company does not sponsor, support, or endorse HondaCarForum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.