Honda Car Forum


 

Go Back   Honda Car Forum - Accord Parts Civic Tuning Acura Racing > Discussion > Honda Technical

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Oct 2007, 05:27 pm
Junior Member
 
Join Date: Oct 2007
Posts: 1
Default 3 weeks ago, my stock radio started smoking from the back, so I removed it permenantly?

Today, the same thing happen with my window controller, it started smoking real bad with the rubber smell, seems like my civics electrical is going out of hand. Its getting to the point where I dont feel safe to drive this car! Does anyone know what is wrong with this car, and how I can fix it, or how much it would cost to fix this, because I dont know nothing about car electricals. Any help would be highly appreciated. Thanks!
Reply With Quote
  #2 (permalink)  
Old 06 Oct 2007, 05:30 pm
Junior Member
 
Join Date: Oct 2007
Posts: 4
Default

I suggest you look at your fuses and the fuseable link real quick as it suggests these are not protecting your electricsThe window fuse could have been replaced with one of to high a valueI had problems a few years ago with a Civic's that lived close to the sea and a lot of corrosion had started in the electricsHow old is the car?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
what does the antenna look like in the back of my radio? any specific color? Tracy W Honda Technical 2 21 Sep 2007 07:08 pm
my MDX Acura is smoking! HELP what can it be? All lights came up and it's smoking. My soysv Acura Technical 4 20 Aug 2007 04:48 pm
by -paasing the stock radio hipnautic Honda 3 1 29 Sep 2006 08:39 pm
Honda Odyssey: 1 second noise at 5 mph when started (started engine as well). varkiliy_jar Honda 2 9 19 Jul 2004 08:22 pm
Honda Odyssey: 1 second noise at 5 mph when started (started engine as well). varkiliy_jar Honda 3 9 19 Jul 2004 08:22 pm


All times are GMT -5. The time now is 08:07 pm.


Attribution:
Honda News | Autoblog
Powered by Yahoo Answers




Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
HondaCarForum.com is not affiliated with Honda Motor Company in any way. Honda Motor Company does not sponsor, support, or endorse HondaCarForum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.