Honda Car Forum


 

Go Back   Honda Car Forum - Accord Parts Civic Tuning Acura Racing > Discussion > Honda Technical

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Mar 2013, 12:25 am
Member
 
Join Date: Aug 2007
Posts: 85
Default Weird engine problem?

Hi , i have a 1995 Honda CRX-Del Sol with a B18c Type R JDM in it. And it wont start anymore here is exactly what happened : When i bought this car is was stored for about 6 months, so when i bought it i started it everyday for about 5 days and i would let it idle 2 to 8 min. then one day it didn't start at all, the next day is started perfectly then i retried to start it again without any luck, than winter came, after winter i changed my distributor ( a week ago ) and it started perfectly than for the following days it would need more and more crank till it would start. yesterday it barelystarted after like 7 cranks. and now it wont start anymore, It looks like my car is killing the distributors for some reason. What can i do about this ? Thanks
Reply With Quote
  #2 (permalink)  
Old 22 Mar 2013, 12:35 am
Junior Member
 
Join Date: Mar 2013
Posts: 1
Default

It sounds like your not getting a spark. You should check for a spark coming from your spark plugs. If your not getting a spark or it is very weak, then you have a electrical problem with the coil, but you did replace the distributor so that should have a new one in it. Might need to replace spark plugs and wires if there is no spark or a weak spark. Might even be the starter.































If you have a good spark, then another thing I would do is turn the key from off to ON(II) and listen for whether the fuel pump primes for 2 seconds and whether the CEL remains on or turns off after 2 seconds. This will help to tell you if the fuel pump is bad or if you need to replace the CEL. If all else fails, then ignition control module needs to be replaced.































The only other thing that I can think of is to stick a code reader on the car and see if it gives you a error code. Just because the check engine light is not on doesn't mean it's not running.
Reply With Quote
  #3 (permalink)  
Old 22 Mar 2013, 12:50 am
Senior Member
 
Join Date: Aug 2007
Posts: 443
Default

Battery? Starter? Wire shortage? Fuel Pump? Maybe not fuel pump, but could be a fuel problem. You cannot just assume it's one thing. Diagnose Everything. See if anything else seems like it could be the problem.
Reply With Quote
  #4 (permalink)  
Old 22 Mar 2013, 01:05 am
Junior Member
 
Join Date: Sep 2007
Posts: 15
Default

the seal on your distributor make sure the o ring is there and seated, it prevents moisture build up inside which can cause this, if you have old distributor try that too, maybe you got a wrong one or faulty one































if any wires are bad or spark plugs not gapped properly or fouled, or faulty ignition wiring maybe you didnt plug it in all the way would cause this, since in a dist system a faulty wire or plug can kill a distributor which is why you replace those all at once and a bad ignition coil also common will cause hot engine starting issues
Reply With Quote
  #5 (permalink)  
Old 22 Mar 2013, 01:21 am
Junior Member
 
Join Date: Apr 2011
Posts: 7
Default

Make sure you replace the o ring on the distributor first, then make sure that you replaced the whole disrtibutor assembly the distributor, the cap, and the rotor. Then replace all you spark plug wires and also spark plugs. This should solve the problem.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
91 Accord - weird problem ddomz Honda Technical 4 15 Jan 2009 04:54 pm
Weird clutch problem - rsx Yoda Acura 2 13 May 2008 09:31 am
95 Civic, weird A/C problem Steven L. Honda 3 3 13 Jul 2007 04:55 pm
weird AC problem nooneinparticular314159@yahoo.com Honda 2 2 15 Jul 2006 09:47 am
Speedometer problem (weird) Boondocks Honda 2 3 29 Dec 2005 04:37 pm


All times are GMT -5. The time now is 07:09 pm.


Attribution:
Honda News | Autoblog
Powered by Yahoo Answers




Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
HondaCarForum.com is not affiliated with Honda Motor Company in any way. Honda Motor Company does not sponsor, support, or endorse HondaCarForum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.