Honda Car Forum


 

Go Back   Honda Car Forum - Accord Parts Civic Tuning Acura Racing > Discussion > Honda Technical

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Mar 2011, 05:46 am
Junior Member
 
Join Date: Jul 2009
Posts: 26
Default Problem with my prelude?

just bought a 90 prelude SI a few days ago, and the speedometer, tachometer, and mileage just stopped working. Anyone know what can be the cause of this? Im not very good with cars so your going to have to dumb down your answer for me. Thanks!
Reply With Quote
  #2 (permalink)  
Old 12 Mar 2011, 06:01 am
Junior Member
 
Join Date: Oct 2007
Posts: 11
Default

sounds like you just blew a fuse is all. check your owner's manual (If you have it) for the guide to which fuse is which and there should be one with the word "Dash" or "Console" on it, and check that one.































If you don't have the manual locate your fuse box (Might even be under the hood) and check all the fuses for a burned out one. You might even find a couple you need to replace.































If you don't feel comfortable with fuses, take it to any dealership or reputable mechanic shop and have them check the fuses for you. Most shops strive for customer service so they'll usually do it for free to make you happy and try to turn you into a returning customer.
Reply With Quote
  #3 (permalink)  
Old 12 Mar 2011, 06:16 am
Junior Member
 
Join Date: Mar 2011
Posts: 4
Default

That sound like you need a new wire somewhere maybe even somethings loose. Just have someone look at it
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
93 Honda Prelude Tranny Problem or engine problem? clist_man Honda Technical 0 26 Oct 2010 03:47 pm
90 Prelude problem? vishis11 Honda Technical 7 06 Jan 2010 09:01 am
Prelude Problem prelude2305 Honda Technical 1 04 Jan 2008 09:26 pm
Problem with '98 Prelude xero Honda 2 2 14 Jul 2004 12:59 pm
Re: 98 prelude problem Andrey Tarasevich Honda 1 1 20 Aug 2003 10:22 pm


All times are GMT -5. The time now is 01:17 pm.


Attribution:
Honda News | Autoblog
Powered by Yahoo Answers




Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
HondaCarForum.com is not affiliated with Honda Motor Company in any way. Honda Motor Company does not sponsor, support, or endorse HondaCarForum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.